
Welcome to StyleWriter Help

Select from the following options for help in using StyleWriter.

· Main StyleWriter Window
(Starter Edition Window)

· How StyleWriter Works

Clipboard Text

Microsoft Word

· StyleWriter's Advice

· Correcting Your Text

· Customizing StyleWriter

Welcome to StyleWriter Help

StyleWriter's Main Window

The Main StyleWriter Window shows three views of your document:

1. The Text View in the right-hand pane displays the text of your document and highlights style and 
usage problems it has found in your writing.  

2. The Sentence View in the left-hand pane shows the length of each sentence and highlights those with 
problems.  It also shows the Bog and Pep found in each sentence.

3. The Sentence Summary shows the distribution of sentences across the sentence length groups.

The key statistics and ratings for your document are in the Status Bar.

The top section shows the text, category and advice for the currently highlighted problem, and lets you 
select the Writing Task and Target Audience for the document.

Click on each part of the image for more details.
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An excellent writing style has the following characteristics:

1. In the Status Bar: 

· A Bog Index, Average Sentence and Passive Index below 20 with Good or Excellent ratings.

2. In the Sentence View: 

· Short red-blue horizontal bars showing readable sentences.

· Green bars showing good use of Pep to add interest to your style.

· Mostly white sentence bars showing clear English.

3. In the Sentence Summary:

· A short, vertical red-blue bar showing the total Bog in your document – red for sentence length; 
blue for word choice.  A score below 20 is excellent.

· A vertical, green bar (over 10 is excellent) showing the total Pep in your document.

· A graph of sentence lengths through the document showing a normal distribution.  This means a 
pyramid shape in the area to the left of the gray zone to show you have varied your sentence 
length.

· No red sentences in the gray zone (considered too long for the writing task you have chosen).

Welcome to StyleWriter Help > StyleWriter's Main Window
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StyleWriter's Main Window (Starter Edition)

The Main StyleWriter Window shows the Text View of your document and highlights style and usage 
problems it has found in your writing.  

The key statistics and ratings for your document are in the Status Bar.

The top section shows the text, category and advice for the currently highlighted problem, and lets you 
select the Writing Task and Target Audience for the document.

Click on each part of the image for more details.

An excellent writing style has a Bog Index, Average Sentence and Passive Index below 20 with Good or 
Excellent ratings.

Welcome to StyleWriter Help > StyleWriter's Main Window

StyleWriter's Menus

StyleWriter's menus give you access to the various analysis, reporting, customizing and help functions of 
the program.  Click on each menu for more information.
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Welcome to StyleWriter Help > StyleWriter's Main Window > StyleWriter's Menus

StyleWriter's File Menu

StyleWriter's menus give you access to the various analysis, reporting, customizing and help functions of 
the program.  Click on each menu for more information.

Opens and closes documents or clipboard text to check.

Welcome to StyleWriter Help > StyleWriter's Main Window > StyleWriter's Menus

StyleWriter's Edit Menu

StyleWriter's menus give you access to the various analysis, reporting, customizing and help functions of 
the program.  Click on each menu for more information.
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Moves around StyleWriter’s advice in the Text Screen.

Welcome to StyleWriter Help > StyleWriter's Main Window > StyleWriter's Menus

StyleWriter's View Menu

StyleWriter's menus give you access to the various analysis, reporting, customizing and help functions of 
the program.  Click on each menu for more information.

Allows different views and levels of StyleWriter’s advice.

Welcome to StyleWriter Help > StyleWriter's Main Window > StyleWriter's Menus

StyleWriter's Analysis Menu

StyleWriter's menus give you access to the various analysis, reporting, customizing and help functions of 
the program.  Click on each menu for more information.
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Shows the full StyleWriter statistics.

Welcome to StyleWriter Help > StyleWriter's Main Window > StyleWriter's Menus

StyleWriter's Tools Menu

StyleWriter's menus give you access to the various analysis, reporting, customizing and help functions of 
the program.  Click on each menu for more information.

Customizes StyleWriter to your needs.

Welcome to StyleWriter Help > StyleWriter's Main Window > StyleWriter's Menus

StyleWriter's Window Menu

StyleWriter's menus give you access to the various analysis, reporting, customizing and help functions of 
the program.  Click on each menu for more information.
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Changes the arrangement of checked document windows.

Welcome to StyleWriter Help > StyleWriter's Main Window > StyleWriter's Menus

StyleWriter's Help Menu

StyleWriter's menus give you access to the various analysis, reporting, customizing and help functions of 
the program.  Click on each menu for more information.

Shows StyleWriter’s comprehensive help screens.

Welcome to StyleWriter Help > StyleWriter's Main Window

StyleWriter's Toolbar

Show Starter Edition Toolbar

StyleWriter's toolbar gives you quick access to the most frequently used commands.  Click on each toolbar 
button for more information.
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StyleWriter's Text View

The highlighted words and phrases in your text show in different colors:

Bold Dark Red Highlights suggested changes from StyleWriter's 
Plain English Style categories.  Following the 
program’s advice will improve the style and 
readability of your writing.  

Normal Red Highlights sentences longer than the Long Sentence 
Limit. The program encourages you to edit long 
sentences by cutting words or breaking them into 
two or three sentences.

Bold Black Shows Word Usage problems, such as Confused 
Words and Hyphen Help where you may have used 
words inappropriately.

Bold Gray Highlights possible confusion or usage issues in the 
Confused Common, Confused Hyphen and Sexist 
Common categories.  These categories are Default 
off.

(Standard and Professional 
editions only)

Highlights Bog words that detract from readability.  
The program highlights them in High Bog Sentences
when High Bog is turned on.
Highlights Abbreviations, Difficult Words and 
Jargon Phrases.  StyleWriter encourages you to keep 
these to a minimum.

Bold Red Highlights Questionable Words.  Issues include 
racist words, inappropriate language, typing errors 
missed by spellcheckers, preferred spelling and 
many other issues.
Highlights spelling and typing errors and incorrect 
capital letter usage.

Normal Green Highlights Pep words or phrases, short sentences or 
questions.

(Standard and Professional 
editions only)

Highlights Glue words in High Glue Sentences when 
High Glue is turned on.
Highlights the problem that the current advice 
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StyleWriter's Sentence View

The Sentence View lets you scan the document to see what section needs the most editing.  

The right-hand side shows bars representing each sentence:

The left-hand side graphs StyleWriter’s assessment of each sentence showing the values it contributes to the 
overall Bog Index.

StyleWriter's Sentence Summary

The Sentence Summary shows the average sentence length and spread of sentence lengths in your document.

message refers to.
Highlights gray quoted text excluded from 
StyleWriter's statistics if you have selected “Exclude 
Quoted Text” in the Style Categories dialog.

The length of each bar shows the number of words in the sentence.  
Vertical lines mark the length in five-word units.
Plain English sentences are white with a dark gray outline and no 
highlighted problems.  Headings have a light gray outline.
Long Sentences, longer than the Long Sentence Limit (shown by 
red vertical lines), are pale red with a red outline.
Each style problem shows in the Style Problem color (dark red by 
default) where the problem occurs in the sentence.
High Bog Sentences (Standard and Professional editions only), 
show each Bog word in the High Bog color.  If not a long sentence, 
the fill is a pale version of the High Bog color.
High Glue Sentences (Standard and Professional editions only), 
show each Glue word in the High Glue color.  If not a long or High 
Bog sentence, the fill is a pale version of the High Glue color.
A heavy base line groups sentences into paragraphs.

A blue line brackets the sentences visible in the Text View, and 
inside that, a gold dot shows the sentence with the currently 
selected problem.
If the current problem is a word or phrase, it has a red surround.  If 
a sentence, it has a gray fill.

The blue bar shows Bog based on the Bog value of words used in the 
sentence. 
The red bar shows Bog based on the number of words in the sentence.
The green bar shows the Pep in each sentence.
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The red and blue column and the green column on the left show the Sentence Bog, Word Bog and Pep that 
make up the Bog Index.

Bog Index = Word Bog (blue) + Sentence Bog (red) – Pep (green)

Welcome to StyleWriter Help

How StyleWriter Works
StyleWriter works by checking the documents already open on your Windows desktop.  To check a 
document, you must first open the document with your word processor.

If StyleWriter can communicate with your word processor to retrieve text and send editing commands, it 
sets up a link that lets StyleWriter work interactively with the word processor (see Using StyleWriter with 
Microsoft Word).

All Windows word processors and text editors can copy text to the Windows clipboard, making it 
available to all other Windows applications.  Microsoft Windows Write and Microsoft Windows Notepad 
are typical applications that do not communicate directly with StyleWriter.  However, you can still check 
text created in these programs through the clipboard.  For more details see Using StyleWriter with 
Clipboard Text.

Welcome to StyleWriter Help > How StyleWriter Works

Using StyleWriter with Microsoft Word

With Microsoft Word, StyleWriter offers interactive editing of your document.  The StyleWriter window 
sits at the top of your screen with Word below so you can make corrections from StyleWriter or edit your 
document in Word.  StyleWriter keeps an up-to-date display of your text and its advice as you work in the 
StyleWriter window.  When editing in Word, the display updates when you click on StyleWriter's 
Resume button.

To get StyleWriter to check your document from Microsoft Word, you can either:

· go to Word’s Tools menu and select StyleWriter…, 
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· click the StyleWriter button in the standard toolbar, or

· in Word 2007, click the StyleWriter button in the Add-Ins tab.

Word calls StyleWriter to start checking your document right away.

Alternatively, you can run StyleWriter from the Start/All Programs menu in Windows.  If you have one 
document open on your desktop, StyleWriter starts checking it immediately.  If you have several 
documents open, StyleWriter displays a list of them for you to choose from.

To check only part of your document, select that part before calling StyleWriter.  See Checking Selected 
Text for more details.

Once you ask StyleWriter to check your document, it sets up interactive communications with Microsoft 
Word and with the text of your document.  This lets StyleWriter make changes to your document while 
still keeping track of the changes you make.

To keep track of text in your document, StyleWriter gathers groups of paragraphs of around three 
thousand characters (4KB maximum).  It creates Bookmarks of these passages so it can quickly refer to 
them within your document when it needs to edit the text or get a fresh copy.

If your document contains sections StyleWriter can't divide into chunks of less than 4KB, it will display as 
much as it can then show the line:

*** Table or Field too big and complex - only first 4k shown ***

This can happen with large field codes like Table of Contents, Bibliography or References that use 
hyperlinks.  If you need StyleWriter to check these, you may be able to do so by selecting just the contents 
of those fields and asking StyleWriter to check the selected text.

If this happens with a large table, see Checking Text In Tables for more details.

Welcome to StyleWriter Help > How StyleWriter Works

Checking Selected Text

To check only part of your document, just select that part of your text before calling StyleWriter.  Before 
StyleWriter opens the document, it will display a dialog asking whether you want to check the selected 
text or the whole document.

If you choose ‘Check Selected text’ and the text you selected doesn’t start and end on a whole sentence, 
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StyleWriter extends the selection to include complete sentences at each end of the text.

Welcome to StyleWriter Help > How StyleWriter Works

Checking Text in Tables

StyleWriter can check the text in Word document tables, but doesn't reproduce the table format.  It 
displays the table text a row at a time, showing each cell in a separate paragraph.  The way it collects the 
text depends on the size and format of the table.

If the table contains less than 4KB of text (4,096 characters including spaces), StyleWriter makes one 
bookmark of it and transfers the text as one item.

If a table contains more than 4KB and does not have any merged cells across two or more rows, 
StyleWriter gathers one or more rows or cells to make up each bookmark.

If a table contains more than 4KB but does have merged cells across two or more rows, StyleWriter can't 
separate the rows, so must take the entire table as a bookmark.  When it then diplays the text of the table 
in the Text View, StyleWriter will show only the first 4KB of it then beep and show the line:

*** Table or Field too big and complex - only first 4k shown ***

If this happens, and you want StyleWriter to check the whole table, you can either:

· go back and split the merged cells so StyleWriter can select discrete rows, or

· split the table into smaller tables of a page each.

Welcome to StyleWriter Help > How StyleWriter Works

Using StyleWriter with Clipboard Text

All Windows word processors and text editors and most other applications can copy text to the Windows 
clipboard for other applications to use.  Microsoft Windows Write and Microsoft Windows Notepad are 
typical applications that do not support interactive communications but use the Windows clipboard.

When you go to StyleWriter's File Menu and select Open, the Select Document box lists any documents 
available on the desktop, including the clipboard if it is not empty.  This lets you check text from other 
applications, whether they are word processor, spreadsheet, database or any other type of application.

To check any text using the clipboard:

1. Start StyleWriter from the Start/All Programs menu in Windows.

2. Switch to the window containing your text and select the text you want to check.  This may be all or 
any part of a document.

3. Copy the text to the clipboard (usually with Ctrl+C).

4. Switch back to StyleWriter (Alt+Tab), click the Open button to start the check.
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To edit your text following StyleWriter's advice, switch back to your original application with the Edit
button or Alt+Tab, and edit as usual.  See Correcting Your Text.

Welcome to StyleWriter Help

StyleWriter's Advice

As StyleWriter checks your document, as well as advising on particular style and usage problems in the 
text, it also: 

1.  Measures and rates your readability and clarity (Bog Index)

2.  Measures and rates your Average Sentence Length

3.  Measures and rates your use of Passive Verbs

4.  Shows your sentence variety

5.  Checks for misspellings

6.  Highlights questionable words or errors missed by spellcheckers

7.  Highlights jargon and abbreviations to discourage their use

8.  Highlights long sentences and High Bog sentences

9.  Highlights wordy sentences (High Glue)

Statistics

We recommend you look at the sentence graphs in StyleWriter’s Main Window and the statistics 
displayed in the Status Bar before you start editing your text.  This way, you’ll get an overall picture of 
your writing and know how much editing you'll need to do.

Click this button to open the Statistical Summary window, or go to the Analysis menu and select 
Statistical Summary.

StyleWriter shows its key statistics on the Status Bar and lets you save them to the Statistics Archive file 
so you can review the effectiveness of its advice on your writing.  

You can also Insert StyleWriter’s Statistics as annotations or footnotes at the start of your document.

Advice Messages

As you move through the problems in your document, StyleWriter displays an appropriate advice message
and the category of the problem in the advice window at the top of the Main StyleWriter Window.  You 
can skip through each bit of text to see all the advice StyleWriter offers before you edit.  

To call up a help screen explaining the category, you can:

·   click on the category, or
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·   select Explain Category in the Help menu.

Style Categories

StyleWriter's patterns are grouped into Categories to help you see where you can improve your writing 
style.  

Click this button to open the Style Categories dialog for a summary of the problems found in each 
category, or go to the Analysis menu and select Style Categories.

Welcome to StyleWriter Help

Moving Through Your Text

You can scroll through the text to see what StyleWriter has highlighted by:

·   pressing the Page Up and Page Down keys,

·   pressing the  and  arrow keys, to scroll one line at a time,

·   pressing the Home and End keys to scroll to the beginning or end,

·   clicking your mouse on the Scroll Bar, or

·   clicking on any sentence in the Sentence View

As you scroll through your text, StyleWriter highlights the words or phrases that match its patterns.

You can move from one highlighted word or phrase (each one a match on a pattern) to another by:

·   pressing the  arrow key or clicking the Next button to move to the next problem,

·   pressing the  arrow key or clicking the Previous button to move to the previous problem, or

·   clicking your mouse on any highlighted word or phrase.  If there are two or more problems 
overlapping in your text where you click the mouse, StyleWriter will display each one in turn with 
each mouse click.

You can move through and edit the text StyleWriter has checked while it is still checking the rest of your 
document.

Welcome to StyleWriter Help

Correcting Your Text
The way you correct your text depends on the application you are using to write it, and whether the 
application supports interactive communications with StyleWriter (see How StyleWriter Works).
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Correcting Text With Microsoft Word

With Microsoft Word, StyleWriter offers interactive editing of your document.  Whether you make 
corrections from StyleWriter or edit your document with the word processor, StyleWriter updates its 
display of your text and provides up-to-date advice and statistics.

Selecting Corrections From StyleWriter's Advice Message

Many of StyleWriter's advice messages offer you replacements in blue underlined text.  You can correct 
your text simply by clicking on the replacement text with your mouse.  You will notice the mouse cursor 
change to a hand as it passes over the replacement text.  When you select a correction, StyleWriter 
corrects your text and moves on to the next highlighted problem.

In some messages, StyleWriter's advice includes the option to delete the highlighted text from your 
document.  To do this, click on DELETE.  The text disappears from your document and StyleWriter 
moves to the next problem.

You should check that your sentence still reads correctly before you decide to use DELETE.  If deleting 
the word or phrase makes the sentence incorrect, use the Edit button to change your text.

Using the Undo Button

The Undo button allows you to undo the corrections you have made when selecting replacement text.  See 
Undo Button for more details.

Using the Edit Button

If you need to change more than a few words (for example, shortening a long sentence or editing out a 
passive verb), or the advice message does not offer a replacement, click on StyleWriter's Edit button.  
This takes you back to your word processor, to the place in your document where StyleWriter found the 
problem.  You can then make the suggested changes.

To return to StyleWriter, click on StyleWriter's Resume button, or press Alt+Tab.  StyleWriter 
automatically rechecks your revised text.

Correcting Clipboard Text

When you are checking clipboard text, StyleWriter has no control over the application that created the 
text.  StyleWriter's editing suggestions in the advice message appear in blue text, and you have to correct 
your text by clicking on StyleWriter's Edit button.

The Edit button shrinks StyleWriter's display and switches you back to the application you came from so 
you can make the suggested changes.  Return to StyleWriter by clicking on StyleWriter's Resume button 
or pressing Alt+Tab.

Tip:  You may want to change the size of your word processor's window, moving it to the bottom of the 
screen so you can still see the StyleWriter window and its advice while you edit.  

Rechecking Your Text

You can ask StyleWriter to recheck your text at any time by sending a fresh copy of your text to the 
clipboard, then clicking StyleWriter's Open button to recheck the clipboard.  

If you lose sight of the StyleWriter screen at any time, you can always return to it by using the Alt+Tab 
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keys together.  This will switch through all the applications you have open on your desktop.

Welcome to StyleWriter Help

Statistical Summary

(Standard and Professional editions only)

The Statistical Summary displays and assesses three important measures of good writing: 

· Average Sentence Length,

· Passive Index and

·   Readability of the documents, expressed either by: 
– Style Index (for continuity with StyleWriter 3), 
– the more comprehensive Bog Index or
– the Stanton-Wright Reading Grade

The Style Index and Bog Index assessments vary according to the writing task and audience you have 
selected in the main window.  If you have chosen to Exclude Quoted Text in the Style Categories dialog, 
these figures will not include quoted text.

The Statistical Summary also displays:

· the percentage of Jargon words and phrases found and

· the percentage of Glue Words in the document.

Click on the ‘+’ to expand each measure, showing its components and how they combine to produce the 
statistic.  Click and drag the frame to enlarge the window, if necessary. 

As you edit the document, StyleWriter updates the statistics in the Redraft column and revises the 
Rating.
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If you have chosen to Save Statistics to Archive File in the Save Options dialog, you can select the 
statistics you want to save using the check-boxes in the Save column.

Welcome to StyleWriter Help > Statistical Summary

Statistical Summary – Average Sentence

(Standard and Professional editions only)

The Statistical Summary displays and assesses three important measures of good writing: 

· Average Sentence Length,

· Passive Index and

·   Readability of the documents, expressed either by: 
– Style Index (for continuity with StyleWriter 3), 
– the more comprehensive Bog Index or
– the Stanton-Wright Reading Grade

The Style Index and Bog Index assessments vary according to the writing task and audience you have 
selected in the main window.  If you have chosen to Exclude Quoted Text in the Style Categories dialog, 
these figures will not include quoted text.

The Statistical Summary also displays:

· the percentage of Jargon words and phrases found and

· the percentage of Glue Words in the document.

Click on the ‘+’ to expand each measure, showing its components and how they combine to produce the 
statistic.  Click and drag the frame to enlarge the window, if necessary. 

As you edit the document, StyleWriter updates the statistics in the Redraft column and revises the 
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Rating.

If you have chosen to Save Statistics to Archive File in the Save Options dialog, you can select the 
statistics you want to save using the check-boxes in the Save column.

Welcome to StyleWriter Help > Statistical Summary

Statistical Summary – Passive Index

(Standard and Professional editions only)

The Statistical Summary displays and assesses three important measures of good writing: 

· Average Sentence Length,

· Passive Index and

·   Readability of the documents, expressed either by: 
– Style Index (for continuity with StyleWriter 3), 
– the more comprehensive Bog Index or
– the Stanton-Wright Reading Grade

The Style Index and Bog Index assessments vary according to the writing task and audience you have 
selected in the main window.  If you have chosen to Exclude Quoted Text in the Style Categories dialog, 
these figures will not include quoted text.

The Statistical Summary also displays:

· the percentage of Jargon words and phrases found and

· the percentage of Glue Words in the document.

Click on the ‘+’ to expand each measure, showing its components and how they combine to produce the 
statistic.  Click and drag the frame to enlarge the window, if necessary. 
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As you edit the document, StyleWriter updates the statistics in the Redraft column and revises the 
Rating.

If you have chosen to Save Statistics to Archive File in the Save Options dialog, you can select the 
statistics you want to save using the check-boxes in the Save column.

Welcome to StyleWriter Help > Statistical Summary

Statistical Summary – Style Index

(Standard and Professional editions only)

The Statistical Summary displays and assesses three important measures of good writing: 

· Average Sentence Length,

· Passive Index and

·   Readability of the documents, expressed either by: 
– Style Index (for continuity with StyleWriter 3), 
– the more comprehensive Bog Index or
– the Stanton-Wright Reading Grade

The Style Index and Bog Index assessments vary according to the writing task and audience you have 
selected in the main window.  If you have chosen to Exclude Quoted Text in the Style Categories dialog, 
these figures will not include quoted text.

The Statistical Summary also displays:

· the percentage of Jargon words and phrases found and

· the percentage of Glue Words in the document.

Click on the ‘+’ to expand each measure, showing its components and how they combine to produce the 
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statistic.  Click and drag the frame to enlarge the window, if necessary. 

As you edit the document, StyleWriter updates the statistics in the Redraft column and revises the 
Rating.

If you have chosen to Save Statistics to Archive File in the Save Options dialog, you can select the 
statistics you want to save using the check-boxes in the Save column.

Welcome to StyleWriter Help > Statistical Summary

Statistical Summary – Bog Index

(Standard and Professional editions only)

The Statistical Summary displays and assesses three important measures of good writing: 

· Average Sentence Length,

· Passive Index and

·   Readability of the documents, expressed either by: 
– Style Index (for continuity with StyleWriter 3), 
– the more comprehensive Bog Index or
– the Stanton-Wright Reading Grade

The Style Index and Bog Index assessments vary according to the writing task and audience you have 
selected in the main window.  If you have chosen to Exclude Quoted Text in the Style Categories dialog, 
these figures will not include quoted text.

The Statistical Summary also displays:

· the percentage of Jargon words and phrases found and

· the percentage of Glue Words in the document.
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Click on the ‘+’ to expand each measure, showing its components and how they combine to produce the 
statistic.  Click and drag the frame to enlarge the window, if necessary. 

As you edit the document, StyleWriter updates the statistics in the Redraft column and revises the 
Rating.

If you have chosen to Save Statistics to Archive File in the Save Options dialog, you can select the 
statistics you want to save using the check-boxes in the Save column.

Welcome to StyleWriter Help > Statistical Summary

Statistical Summary – Bog Index +

(Standard and Professional editions only)

The Statistical Summary displays and assesses three important measures of good writing: 

· Average Sentence Length,

· Passive Index and

·   Readability of the documents, expressed either by: 
– Style Index (for continuity with StyleWriter 3), 
– the more comprehensive Bog Index or
– the Stanton-Wright Reading Grade

The Style Index and Bog Index assessments vary according to the writing task and audience you have 
selected in the main window.  If you have chosen to Exclude Quoted Text in the Style Categories dialog, 
these figures will not include quoted text.

The Statistical Summary also displays:

· the percentage of Jargon words and phrases found and

· the percentage of Glue Words in the document.
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Click on the ‘+’ to expand each measure, showing its components and how they combine to produce the 
statistic.  Click and drag the frame to enlarge the window, if necessary. 

As you edit the document, StyleWriter updates the statistics in the Redraft column and revises the 
Rating.

If you have chosen to Save Statistics to Archive File in the Save Options dialog, you can select the 
statistics you want to save using the check-boxes in the Save column.

Welcome to StyleWriter Help > Statistical Summary

Statistical Summary – Reading Grade

(Standard and Professional editions only)

The Statistical Summary displays and assesses three important measures of good writing: 

· Average Sentence Length,

· Passive Index and
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·   Readability of the documents, expressed either by:
– Style Index (for continuity with StyleWriter 3), 
– the more comprehensive Bog Index or
– the Stanton-Wright Reading Grade

The Style Index and Bog Index assessments vary according to the writing task and audience you have 
selected in the main window.  If you have chosen to Exclude Quoted Text in the Style Categories dialog, 
these figures will not include quoted text.

The Statistical Summary also displays:

· the percentage of Jargon words and phrases found and

· the percentage of Glue Words in the document.

Click on the ‘+’ to expand each measure, showing its components and how they combine to produce the 
statistic.  Click and drag the frame to enlarge the window, if necessary. 

As you edit the document, StyleWriter updates the statistics in the Redraft column and revises the 
Rating.

If you have chosen to Save Statistics to Archive File in the Save Options dialog, you can select the 
statistics you want to save using the check-boxes in the Save column.

Welcome to StyleWriter Help > Statistical Summary

Statistical Summary – Jargon

(Standard and Professional editions only)

The Statistical Summary displays and assesses three important measures of good writing: 

· Average Sentence Length,
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· Passive Index and

·   Readability of the documents, expressed either by:
– Style Index (for continuity with StyleWriter 3), 
– the more comprehensive Bog Index or
– the Stanton-Wright Reading Grade

The Style Index and Bog Index assessments vary according to the writing task and audience you have 
selected in the main window.  If you have chosen to Exclude Quoted Text in the Style Categories dialog, 
these figures will not include quoted text.

The Statistical Summary also displays:

· the percentage of Jargon words and phrases found and

· the percentage of Glue Words in the document.

Click on the ‘+’ to expand each measure, showing its components and how they combine to produce the 
statistic.  Click and drag the frame to enlarge the window, if necessary. 

As you edit the document, StyleWriter updates the statistics in the Redraft column and revises the 
Rating.

If you have chosen to Save Statistics to Archive File in the Save Options dialog, you can select the 
statistics you want to save using the check-boxes in the Save column.

Welcome to StyleWriter Help > Statistical Summary

Statistical Summary – Glue

(Standard and Professional editions only)

The Statistical Summary displays and assesses three important measures of good writing: 
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· Average Sentence Length,

· Passive Index and

·   Readability of the documents, expressed either by:
– Style Index (for continuity with StyleWriter 3), 
– the more comprehensive Bog Index or
– the Stanton-Wright Reading Grade

The Style Index and Bog Index assessments vary according to the writing task and audience you have 
selected in the main window.  If you have chosen to Exclude Quoted Text in the Style Categories dialog, 
these figures will not include quoted text.

The Statistical Summary also displays:

· the percentage of Jargon words and phrases found and

· the percentage of Glue Words in the document.

Click on the ‘+’ to expand each measure, showing its components and how they combine to produce the 
statistic.  Click and drag the frame to enlarge the window, if necessary. 

As you edit the document, StyleWriter updates the statistics in the Redraft column and revises the 
Rating.

If you have chosen to Save Statistics to Archive File in the Save Options dialog, you can select the 
statistics you want to save using the check-boxes in the Save column.

Welcome to StyleWriter Help

Style Categories

(Standard and Professional editions) Show Starter Edition.
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The Style Categories dialog shows the number of pattern matches StyleWriter has found in each of its 
Style Categories.  This helps you identify where your writing problems lie and how much editing you'll 
need to do.

Selecting Categories

You can change the categories you want StyleWriter to highlight in your text at any time.  The active 
categories have a checked box next to the category name.  To turn a category on or off, click on the 
category’s check box or press Tab to select the category and then press the Space bar.

If there are no pattern matches against a category, there is no need to turn it off.  We recommend when 
you start using StyleWriter that you keep the original category defaults.

Commands Available

OK leaves the window and saves any changes you have made.
Cancel closes the window without saving any changes.

Help displays this screen.
Category 

Help
displays help screens about the highlighted category.  To make this button 
active, click on the category you want information about.

Appearance opens the Display Options dialog where you can change the color, size and font 
attributes of each category group.

All Off turns all the categories off.  When you do this, the button changes to All On 
which you can click if you want to make all categories active.

Get Defaults restores the last settings you saved as defaults.
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The pre-set defaults have three Word Usage Categories turned off.  These are Confused Common, 
Confused Hyphen, and Sexist Common.  Abbreviations, Jargon Phrases, High Bog and High Glue 
sentences are On by default, but you can turn them on or off using the toolbar buttons.

Pep and “Exclude quoted text” default off.  If you want to see the words that contribute to Pep, turn this 
category on.  To exclude quoted text from your analysis, turn on the “Exclude quoted text” category.

To change the default categories (those that will be on each time you start), select the categories you want 
and click the Set Defaults button.

Welcome to StyleWriter Help

All Words List

(Professional edition only)

StyleWriter collects lists of all the words (and many phrases) in your document, sorted by word (or 
phrase) type.

In the Editor' list dialog:

· You can choose whether to sort the lists alphabetically or by frequency.

· Double-click a word or phrase to select it in the Text View without closing the Editor's List.

Set Defaults saves the current settings as defaults.  This setting will stay until you reset the 
defaults.

Add 
Category

adds up to four User-defined Categories you can use to add your own patterns 
(see Tailoring StyleWriter’s Patterns).
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· Select one or more entries in a list then click the Trace in Text View button to close the Editor's List 
dialog and highlight these words in the Text View.

· Click the Close button or press the Esc key to close the dialog.

· Select a list then click the Save button to save the list in a text file.

All words lists all the words in your document except those called Odds and ends.

Glue words are the 200 or so most common words in the English language (see High Glue Sentences).

Short list lists all words except Glue words and Odds and ends.

Welcome to StyleWriter Help > Editor's Lists

Spelling List

(Professional edition only)

StyleWriter collects lists of all the words (and many phrases) in your document, sorted by word (or 
phrase) type.

In the Editor' list dialog:

· You can choose whether to sort the lists alphabetically or by frequency.

· Double-click a word or phrase to select it in the Text View without closing the Editor's List.

· Select one or more entries in a list then click the Trace in Text View button to close the Editor's List 
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dialog and highlight these words in the Text View.

· Click the Close button or press the Esc key to close the dialog.

· Select a list then click the Save button to save the list in a text file.

Unknown words are those not found in StyleWriter's dictionary, and therefore possible spelling errors.  
StyleWriter will suggest the correct spelling where possible when you select these words in the Text 
Window (see Spellchecker).  You also have the option to add them to the dictionary. 

Questionable words are those that are probably incorrect or inappropriate.

Unusual Words are correctly spelled but may not be the word you intended.

Added words are those you have added to StyleWriter's dictionary (see Adding to the dictionary).

Welcome to StyleWriter Help > Editor's Lists

Bog List

(Professional edition only)

StyleWriter collects lists of all the words (and many phrases) in your document, sorted by word (or 
phrase) type.

In the Editor' list dialog:

· You can choose whether to sort the lists alphabetically or by frequency.

Page 29 of 55Using StyleWriter

2/25/2017file:///C:/Users/Jack3/AppData/Local/Temp/~hhEC97.htm



· Double-click a word or phrase to select it in the Text View without closing the Editor's List.

· Select one or more entries in a list then click the Trace in Text View button to close the Editor's List 
dialog and highlight these words in the Text View.

· Click the Close button or press the Esc key to close the dialog.

· Select a list then click the Save button to save the list in a text file.

See:

Heavy words

Style words

Specialist words

Welcome to StyleWriter Help > Editor's Lists

Wordy List

(Professional edition only)

StyleWriter collects lists of all the words (and many phrases) in your document, sorted by word (or 
phrase) type.

In the Editor' list dialog:

· You can choose whether to sort the lists alphabetically or by frequency.
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· Double-click a word or phrase to select it in the Text View without closing the Editor's List.

· Select one or more entries in a list then click the Trace in Text View button to close the Editor's List 
dialog and highlight these words in the Text View.

· Click the Close button or press the Esc key to close the dialog.

· Select a list then click the Save button to save the list in a text file.

See:

Passive Verbs

Hidden Verbs

Wordy Phrases

Welcome to StyleWriter Help > Editor's Lists

Jargon List

(Professional edition only)

StyleWriter collects lists of all the words (and many phrases) in your document, sorted by word (or 
phrase) type.

In the Editor' list dialog:

· You can choose whether to sort the lists alphabetically or by frequency.
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· Double-click a word or phrase to select it in the Text View without closing the Editor's List.

· Select one or more entries in a list then click the Trace in Text View button to close the Editor's List 
dialog and highlight these words in the Text View.

· Click the Close button or press the Esc key to close the dialog.

· Select a list then click the Save button to save the list in a text file. 

· The jargon phrases in the list will change depending on the Jargon Score threshold chosen in the 
Category Summary.  This threshold appears in brackets at the top of the list.

See:

Abbreviations

Difficult Words

Jargon Phrases

Welcome to StyleWriter Help > Editor's Lists

Pep List

(Professional edition only)

StyleWriter collects lists of all the words (and many phrases) in your document, sorted by word (or 
phrase) type.
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In the Editor' list dialog:

· You can choose whether to sort the lists alphabetically or by frequency.

· Double-click a word or phrase to select it in the Text View without closing the Editor's List.

· Select one or more entries in a list then click the Trace in Text View button to close the Editor's List 
dialog and highlight these words in the Text View.

· Click the Close button or press the Esc key to close the dialog.

· Select a list then click the Save button to save the list in a text file.

Interest words:  Most writing consists of the same 5,000 to 10,000 words, used and reused in document 
after document.  In business and government writing this produces a predictable style based on overused, 
dull and abstract words.  Although good writing means choosing simple and familiar words, there's scope 
for interesting words.  StyleWriter's wordlist classifies around 50,000 words as interesting, specific words.

Names:  Names, or proper nouns, are another way to make writing specific and interesting.  Good writing 
is full of people and places rather than abstract words.  The Pep score counts proper nouns in its formula.

Conversational includes contractions, personal pronouns, phrasal verbs, questions and short sentences.

See Pep score

Welcome to StyleWriter Help > Editor's Lists

User List

(Professional edition only)

StyleWriter collects lists of all the words (and many phrases) in your document, sorted by word (or 
phrase) type.

Page 33 of 55Using StyleWriter

2/25/2017file:///C:/Users/Jack3/AppData/Local/Temp/~hhEC97.htm



In the Editor' list dialog:

· You can choose whether to sort the lists alphabetically or by frequency.

· Double-click a word or phrase to select it in the Text View without closing the Editor's List.

· Select one or more entries in a list then click the Trace in Text View button to close the Editor's List 
dialog and highlight these words in the Text View.

· Click the Close button or press the Esc key to close the dialog.

· Select a list then click the Save button to save the list in a text file.

The User List tab will list all House Style problems and add a column for each Added Category.  

See:

House style

User-defined Categories

Welcome to StyleWriter Help > Editor's Lists

Graded List

(Professional edition only)

StyleWriter collects lists of all the words (and many phrases) in your document, sorted by word (or 
phrase) type.
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In the Editor' list dialog:

· You can choose whether to sort the lists alphabetically or by frequency.

· Double-click a word or phrase to select it in the Text View without closing the Editor's List.

· Select one or more entries in a list then click the Trace in Text View button to close the Editor's List 
dialog and highlight these words in the Text View.

· Click the Close button or press the Esc key to close the dialog.

· Select a list then click the Save button to save the list in a text file.

The Graded Lists sorts all words according to their contribution to the Stanton-Wright Reading Grade
formula.

Welcome to StyleWriter Help

Customizing StyleWriter

To customize StyleWriter's analysis of your documents, look at:

Writing Task to adjust analysis to your current task,

Audience to adjust analysis for your intended readers,

Style Categories dialog to set the active style categories,

Tailoring StyleWriter's Patterns to add or delete advice.
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To customize the StyleWriter window and the way StyleWriter works with your word processor, see:

Save Options for saving your document or archiving statistics,

Display Options for changing StyleWriter’s font style and colors, or

View Options to change the way the StyleWriter window behaves.

_______________

See also

How StyleWriter Works

Save Options Dialog

In the Options dialog, click the tab to switch between Save Options, Display Options or View Options.

In the Save Options dialog:

· Check the Save unsaved documents before editing check box if you want StyleWriter to save unsaved 
documents before checking.

· Check the Ask before saving check box if you want StyleWriter to prompt you to save unsaved 
documents before checking.

· Check the Save statistics to archive file check box if you want StyleWriter to save the document 
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statistics before and after editing.  You can select the statistics to save in the Statistical Summary.

· Enter the path of the Archive File where you want StyleWriter to save the statistics.  You can use the 
Browse… button to browse for the file.

· Check the Save place mark in document check box if you want StyleWriter to save a bookmark in your 
document at the start of the next problem it has found.  Next time you run StyleWriter on the same 
document, it will then resume checking where you left off. 

· Tick the Disable Word’s screen while gathering text check box to stop Word from scrolling through 
your document as it gathers the text.  If StyleWriter ever fails to complete this operation, you should leave 
Word’s screen enabled.

Display Options Dialog

In the Options dialog, click the tab to switch between Save Options, Display Options or View Options.

In the Display Options dialog, select the type of highlight you want to change from the list and use the buttons 
to change the size, type or attributes of the display.  

If you have added categories, they will appear in the list as well, so you can change their color, bold and 
underline attributes.

View Options Dialog
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In the Options dialog, click the tab to switch between Save Options, Display Options or View Options.

The View Options dialog lets you change the way the StyleWriter window behaves.  

· Determine which mode StyleWriter starts up in by choosing either Text View only or Split Screen with 
Sentence View.  The default is Split Screen.

· Select a number from the Word length visible in graph drop-down list to determine the width of the 
Sentence View and Sentence Summary.  The default setting is 60, showing the full Sentence Summary 
graph, but you can choose lengths in 5-word increments down to 30 words.

· Determine which measures are displayed in the Status Bar by choosing either Bog Index or Style Index
and either Ave Sentence or Reading Grade.

· Check the Show debugging window check box if you want StyleWriter to start up showing debugging 
information in a separate window.

· Check the Always on top check box if you want the StyleWriter window to stay on top of other 
windows.  This defaults to Off, but the window will stay on top when you click the Edit button to edit 
your document.

· Check the Shrink StyleWriter on Edit command check box if you want the StyleWriter window to 
shrink to just three lines of text while editing in your document.  This reduces the area obscured by 
StyleWriter if you have selected Always on top.  This defaults to On.

· Check the ‘Resume’ when StyleWriter activated check box if you want StyleWriter to refresh the text 
as soon as you return to the StyleWriter window after editing, without having to click the Resume button.  
This defaults to On.
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Statistics Archive File

StyleWriter can save statistics of the documents you check, both before and after editing.  As it finishes 
checking each document, it can record the statistics with Date & time,  document name, "Original" and the 
Author’s name in a text file with each field separated by tabs.  When you close the document after making 
editing changes, StyleWriter records the statistics again, following the  document name with "Redraft".

You can open this file with your word processor to review the changes in your statistics.  By converting the 
text to a table, you will see something like this.

Remember when opening the file that it has a ".txt" file extension.  Remember too, to close the file before 
using StyleWriter again so StyleWriter can write to the file.

Use the Save Options dialog to select or create an archive file.  If you don't want to save statistics, deselect the 
Save statistics to archive file check box.

When Save statistics to archive file is selected, the check boxes in the Statistical Summary dialog become 
available and you can select the statistics you want to save.

Welcome to StyleWriter Help > Customizing StyleWriter

Tailoring StyleWriter's Patterns

Add New Pattern (Standard and Professional editions only)

StyleWriter lets you add your own patterns so you can find particular problems that you may come across 
in your documents.  These can be anything from your own common typing errors to special rules or 
conventions for your organisation.

To add a pattern to StyleWriter, go to the Tools menu and select Add New Pattern... to open the Add 
Pattern dialog.

Delete Pattern (Standard and Professional editions only)

If StyleWriter highlights a word or phrase you do not want highlighted in the future, you can delete the 
pattern from StyleWriter so it won't appear again.

To Delete a pattern, go to the Tools menu and select Delete Pattern... to open the Delete Pattern dialog.

Making an Exception Pattern

If StyleWriter highlights a word or phrase you do not want highlighted in its particular context, you can 
make an exception pattern for that context.

Date & Time Document Draft Total 
Words

Average 
Sentence

Passive 

Index

Bog 
Index

Pep 
Index

Jargon Glue
%

Author

14/05/09 3:20 Report 1.doc Original 6889 22.1 87 150 8 25 51 Nick Wright
14/05/09 4:35 Report 1.doc Redraft 4342 18.3 10 31 14 5 47 Nick Wright
15/05/09 11:50 Letter 23 Original 253 31.2 65 219 10 10 56 Nick Wright
15/05/09 12:10 Letter 23 Redraft 185 18.5 10 20 13 0 43 Nick Wright
15/05/09 11:50 Allcomp Original 123 29.0 75 189 16 0 44 Nick Wright
15/05/09 12:10 Allcomp Redraft 85 15.4 0 12 18 0 41 Nick Wright
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For example, StyleWriter highlights facilities as an Abstract Word.  If you often write about facilities 
management, rather than deleting the pattern you might want to make this an exception to the general 
pattern.  This means that StyleWriter still highlights facilities on its own but not when you write facilities 
management.

To make an exception, go to the Tools menu and select Make an Exception... to open the Make an 
Exception dialog.

When you add new patterns or make exceptions to added patterns, StyleWriter saves them in a separate 
file, the Added Pattern File.  Users can create individual files for their added patterns, and can even create 
several different files of added patterns for use with different types of documents.

When you make exceptions to StyleWriter’s main patterns, StyleWriter saves them in an Exceptions file 
with the same name as the main Pattern File, but with the extension .ptx.  If you use more than one 
Pattern File (maybe to switch between UK and US advice), you may need to add the exceptions for both.

Add New Category (Standard and Professional editions only)

StyleWriter lets you add up to four user-defined categories so you can add specific types of patterns.  For 
example, you may add a category for Banned Wording to hold patterns for all the expressions you don’t 
want your staff to use, or another for Required Wording with patterns that find key phrases and messages 
suggesting the correct text.

To add a category to StyleWriter, open the Style Categories dialog and click Add Category.  StyleWriter 
will prompt you to give the new category a name.  It stores the name in the current Added Pattern File 
with the added patterns.  You can rename the added categories by selecting the category in the Style 
Categories dialog and clicking the Rename button.

User-defined categories don’t contribute to StyleWriter’s Bog Index or Style Index.

You can review the patterns you have added or deleted in the Review Changed Patterns dialog.

Welcome to StyleWriter Help > Customizing StyleWriter > Tailoring StyleWriter's Patterns

Add Pattern

(Standard and Professional editions only)

StyleWriter lets you add your own patterns so you can find particular problems that you may come across 
in your documents.  These can be anything from typing errors missed by a spellchecker to special rules or 
conventions for your organisation.  
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To add a pattern, fill in the following details:

1. In the Pattern to Find field, enter the word or phrase you want to find.  The pattern can include:

·   lowercase letters, hyphens, apostrophes and spaces to match on normal words without being case-
sensitive,

·   uppercase or lowercase letters with a backslash (\) in front of them making them case-sensitive, and 
making the pattern more specific,

·   any other keyboard characters provided you put a backslash (\) in front of them to distinguish them 
as exact characters, or

· Wild Cards to make the pattern more general. 

    Press the Tab key to move to the Category box.  As you leave the Pattern field, StyleWriter checks the 
validity of your pattern.  If you have used Wild Cards, StyleWriter displays a warning, asking you to 
confirm that you intend to do so.  See Wild Cards for more information.

2. In the Category field, click on the arrow to see the list of categories, or use the down arrow key to select 
the category you want.  You can add patterns to most of the style categories and the user-defined 
categories.

    Press the Tab key to move to the Advice Message box.

3. In the Advice Message box, type the message you want StyleWriter to display.  Use the Enter key to 
end a line.  Your message can be up to four lines long without having to scroll, and you must have a 
message on at least one line before you can add the pattern.

·   If you want to include suggested replacement text that users can click on in your message, put 
square brackets around it like [this].  For more details, see Adding Suggested Replacements to 
Advice Messages.

·   StyleWriter assigns a number to the new message.  You can use this message again when you are 
adding later patterns by clicking on the number field and selecting the number of the earlier 
message.  This will save you time if you want to add many patterns with the same advice.
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·   If you want to use an earlier message as the basis for a new message, select the message by scrolling 
through the message numbers to find the one you want.  It can be one you added to a different 
category.  Go back to the right category and to the new number for that category, and you can edit 
the message.

4. When you have finished, press the Tab key and click the Add button and StyleWriter adds the pattern.

You can review the patterns you have added by selecting Review Changed Patterns.

Note: The Auto check box is available in the Professional edition only, and is for advanced users.  See 
Advanced Techniques

Welcome to StyleWriter Help > Customizing StyleWriter > Tailoring StyleWriter's Patterns

Add Preferred Capitalization Pattern

(Standard and Professional editions only)

StyleWriter lets you add your own patterns so you can find particular problems that you may come across 
in your documents.  These can be anything from typing errors missed by a spellchecker to special rules or 
conventions for your organisation.  

To add a Preferred Capitalization pattern, fill in the following details:

1. In the Preferred Form of Word or Phrase field, enter the word or phrase exactly as you want it used.

    Press the Tab key to move to the next field.  As you leave the Preferred Form of Word or Phrase field, 
StyleWriter suggests the patterns and message you need.

·   It converts your preferred form to an exact pattern by placing a backslash (\) before each non-space 
character.  If you have used any characters that can be Wild Cards (such as a capital S or a period), 
StyleWriter displays a warning asking you to confirm that you intend to do so.  See Wild Cards for 
more information. 

·   In the Pattern to Find field, it creates a non-case-sensitive pattern to find all forms of your word or 
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phrase.

·   In the Advice Message field, it suggests the message that lets the user correct the word or phrase to 
the preferred form.  The suggested replacement will start with a backslash (\) to stop StyleWriter 
from adjusting the capitals to suit the style of the existing text.

·   StyleWriter assigns a number to the new message.  You can use this number in the normal Add 
Pattern dialog if you want to add a another incorrect form that will use the same message and 
exception pattern.

You can edit any of these fields if you don’t think they will give the result you want.

2. In the Category field, click on the arrow to see the list of categories, or use the down arrow key to select 
the category you want.

3. When you have finished, press the Tab key and click the Add button and StyleWriter adds the patterns.

You can review the patterns you have added by selecting Review Changed Patterns.

Wild Cards and Pattern Modifiers

You can use wild cards to make your added patterns 

more powerful by picking up word variants, or 

more precise by being case-specific.

The * wild card

The * wild card matches any number of letters, hyphens or apostrophes in a word or different words in a 
phrase.  For example:

The @ wild card

The @ wild card matches up to one letter, hyphen or apostrophe.  Its main uses are at the end of a word to 
match variants of words with different spelling and to set maximum word length.  For example:

Pattern Will match with
Are *stood / are stood

are understood
are misunderstood

Are * stood / are being stood
are never stood
are often stood
are not stood

Pattern Will match with
ascend@@ / ascend, ascends, ascended
climb@@@ up / climb up, climbs up, climbed up, 

climbing up
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Note:  If you use the @ wild card on the end of a word, you should add a space before the backslash to avoid 
matches on longer words.

The ? wild card

The ? wild card matches exactly one letter, hyphen or apostrophe.  Its main uses are to find tense or spelling 
variations or to set minimum word length.  For example:

The # wild card

The # wild card matches a hyphen, space or no character.  Its main use is to find words written with a hyphen, 
as one joined word or as two separate words.  For example:

The . wild card

The . wild card matches a hyphen or space.  Its main use is to find words that should be joined as one word.  
For example:

The ^ wild card

The ^ wild card matches a hyphen or no character.  Its main use is to find words that should be two separate 
words.  For example:

The ~ wild card

The ~ wild card matches a space or no character.  Its main use is to find words that should have a hyphen.  For 
example:

cho@se / chose, choose

Pattern Will match with
f?ll on / full on, fall on, fell on
are ????* hit / are being hit

are frequently hit
are then hit

Pattern Will match with
set#up / set-up

set up
setup

re#sign / re-sign
resign
re sign

Pattern Will match with but not
set.up / set-up or set up setup
re.sign / re-sign or re sign resign

Pattern Will match with but not
set^up / set-up or setup set up
re^sign / re-sign or resign re sign

Pattern Will match with but not
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The ! wild card

The ! wild card matches an optional s.  Its main use is to pick up both singular and plural of words.  For 
example:

The S wild card

The S wild card matches an optional s with or without an apostrophe on either side.  It picks up singular, plural 
and possessive nouns.  For example:

The = wild card

The = wild card matches any number, including decimal point and commas.  For example:

The + wild card

The + wild card matches a single digit from 0 to 9.  For example:

Note: If you use a wild card when adding a pattern, a message appears asking you to confirm it.  If you meant 
to match exactly that character, go back to the Pattern field and insert a backslash (\) before the exact 
character.

The \ modifier

Using a \ before a character forces StyleWriter to match only that exact character.  Use this to match any non-
alphabetic character other than space, apostrophe and hyphen, or any alphabetic character where you want to 
be case sensitive.  For example:

set~up / set up or setup set-up
re~sign / re sign or resign re-sign

Pattern Will match with
examination! / Examination

examinations

Pattern Will match with
dogS head! / Dogs Head

dog's head
dogs' heads
dog head
dog heads

Pattern Will match with
= micron / 1.5 micron

54,321 micron

Pattern Will match with
\1++ / 100 

101 
102 
…
199
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The & modifier

Using a & after a character forces StyleWriter to match only an uppercase character.  Use this with a ? to 
match any uppercase character.  For example:

The % modifier

Using a % after a character forces StyleWriter to match only a lowercase character unless at the start of a 
sentence.  Use this to match a word that would only have a capital when starting a sentence, or to make an 
exception pattern for one that should. See: Make an Exception for making exceptions.  For example:

Adding Suggested Replacements to Advice Messages

The [...] brackets

To include suggested replacement text that users can click on in your message, put square brackets around it 
like [this].  StyleWriter will change the case of the replacement to match the text it found, either all 
lowercase, all UPPERCASE or Capitalized.  

The \ backslash

To stop StyleWriter matching the case of the replacement to that of the matched text, insert a backslash in 
front of the replacement.

Pattern Will match with but not
\penny / penny Penny
\Institute / Institute institute
\R\A\N / RAN ran

Pattern Will match with but not
a& ?&* / A Smith or A Jones A smith or a Jones
?&?&?& / RAN or BBC etc ran

Pattern Will match with
file transfer / File Transfer 

File transfer and
file transfer (the desired form)

Exception pattern Will match with 
(and exclude if added as an exception)

f%ile t%ransfer / File transfer (starting a sentence) and 
file transfer (in the body)

Message Matched text Displayed advice
[need] require need

Require Need
REQUIRE NEED

Message Matched text Displayed advice
[\department] section department

Section department
SECTION department
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The * match place-holder

If you want to include the matched text in your message, insert an asterisk (*) where you want it to go.  One 
special case of this is in the [DELETE] feature.  If you want to suggest deleting the matched text, include the 
uppercase word "DELETE" in square brackets followed by a space and an asterisk:

The ^ add Capital and ~ remove capital

To change the capitalization of the matched text use an asterisk * inside the brackets with a caret ^ after the 
asterisk to force a capital, or a tilde ~ to remove it. 

Advanced features for Suggestions in Advice Messages

If you want to add messages that cover lots of word variants, you should take a deep breath and study the 
following example carefully.

When adding suggestions to advice messages, you can use several features to make them match word variants 
found by your pattern.  The following message shows five of these features.

Pattern:

accompan?@@@ /

Because of the wild cards in the pattern, the matched text could be:

accompany, accompanies, accompanied or accompanying

Message:

[*{accompan/ying/ies/ied/y}escort/ing/s/ed/],  [*go/ing/es/~/| with],  [*went/~/~//~| with]

This message offers two alternatives to replace the matched text.  To cope with the various alternatives it might 
find in the matched text, the message uses the following:

The * match place-holder

Placing * as the first character inside each bracket says “start with the matched text”.

The {...} braces

Message Matched text Displayed advice
[DELETE] * required DELETE required

Message Matched text Displayed advice
Use a capital 
[*^]

london Use a capital 
London

Use lowercase 
[*~]

Departmental Use lowercase 
departmental
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The text inside the curly braces (the CUT text) tells StyleWriter what to cut from the matched text.  The CUT 
text need not be the whole of the matched text or even a whole word.  The text following the braces (the PUT 
text) is put into the suggestion in place of the CUT text.  If there is no backslash in front of the PUT text it is 
converted to the same capitalization as the matched text.

If later suggestions in the same message do not specify CUT text (as in this example), StyleWriter CUTs the 
same text as for the previous suggestion, using the PUT text specified in the suggestion.  Suggestions after 
these can redefine the CUT text if needed.

The / tail separator

Both the CUT text and PUT text can have a stem with alternative tails separated by a slash.  Put the longest 
tails first to avoid the possibility of false matches.  StyleWriter will find the CUT text tail that fits the 
matched text (ignoring case), and use the corresponding tail for the PUT text.  When using the slash to show 
alternative endings, StyleWriter only fits the resulting CUT text with whole words – so it won't find 
accompany in accompanying as it would if not using slashes.  StyleWriter lets each stem have up to 16 
alternative tails, each tail being up to 15 characters long.

Note that in the example, two of the PUT texts have nothing for the fourth tail, but they still need the fourth 
slash.  The CUT text can also end with a slash if the stem is the full word of one of your variants.

The /~ tail

If a CUT text tail doesn't apply for one of the suggestions, use the ~ for that tail in the PUT text and 
StyleWriter will ignore that suggestion when it finds that tail.  In the example above, the third tail for the 
CUT text makes accompanied, which doesn't have a corresponding variant of go with.  Using ~ for the third 
tail of go with means that suggestion will be ignored for accompanied.  In this case we have added a 
suggestion went with which has the ~ tail for all but the third variant.

The | ending separator

If a suggestion has more words after the stem/tail combination, use the vertical bar | to indicate the end of the 
tails then add the ending which will appear after all valid combinations.  In our example, both the going with 
and went with suggestions use this feature.  Without this the word with would appear only with the last tail.

The pattern and message above would result in these messages:

Note: If none of the CUT text endings fit the matched text, the suggestion is blank.  The pattern 
example above would have an unintended match on a typographical error such as 
accompaneis.  The CUT text in the message example would not fit, so the suggestion would be 
blank.

The /= tail

If one of the suggestions has the same tails as the matched text for all variants, you can use just one tail /= and 
StyleWriter will use the same endings for that suggestion as it found in the matched text.  If the suggestion 
has different endings for the first variants but the same endings for the rest, the /= tail can replace the 
remaining endings.

Matched text Message
accompany escort,  go with
accompanies escorts,  goes with
accompanied escorted,  went with
accompanying escorting,  going with
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More advanced features in Advice Messages

Using the * wild card in CUT text

The asterisk has a similar function in the CUT text of a suggestion as it has in patterns, except that instead of 
matching only non-blank characters, it matches anything.  For example:

Pattern:

section + of the * * * \Act ++++ /

Because of the wild cards in the pattern, this would find, among other things:

Section 3 of the Harbors and Foreshores Act 1987

Message:

[*{section * of the}\s*,]

This message CUTs Section 3 of the and sets the asterisk equal to the character 3.  The PUT text becomes s3,
(the backslash forces lower case), so the suggestion becomes:

s3, Harbors and Foreshores Act 1987

Using multiple * wild cards in CUT text

If our house style said drop the year in the abbreviated form, we could add more asterisks to the CUT text:  

Message:

[*{section * of the * Act *}\s*, * Act]

StyleWriter fits the CUT text by equating the first asterisk with 3, the second with Harbors and Foreshores and 
the third with 1987 so the CUT text becomes the entire matched text.  The PUT text uses only two of the 
asterisks, so the suggestion becomes:

s3, Harbors and Foreshores Act

StyleWriter can assign up to five asterisks in CUT text, and inserts them into the PUT text in the same order.

Using multiple CUT texts in a suggestion

If in our previous example, our house style dictated putting the section number after the name of the Act, we 
would need to reverse the order.  One way to do this is to explicitly cut all possible section numbers:

Message:

[*{section 1 of the *}*, s1{section 2 of the *}*, s2{section 3 of the *}*, s3{section 4 of the *}*, s4{section 5 
of the *}*, s5{section 6 of the *}*, s6{section 7 of the *}*, s7{section 8 of the *}*, s8{section 9 of the *}*, 
s9]
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The first two CUTs would fail, but the third (with section 3) would fit leaving the asterisk equating to Harbors 
and Foreshores Act 1987 and the suggestion:

Harbors and Foreshores Act 1987, s3

This is rather a laborious way to do the job, but it demonstrates the multiple CUT texts.  StyleWriter actually 
lets you rearrange the asterisks in the PUT text by numbering them.  This would produce the same result:

Message:

[*{section * of the *}*2, s*1]

Welcome to StyleWriter Help > Customizing StyleWriter > Tailoring StyleWriter's Patterns

Delete Pattern

(Standard and Professional editions only)

If StyleWriter highlights a word or phrase you do not want highlighted in the future, you can delete the 
pattern from StyleWriter so it won't appear again.

The Delete Pattern box shows:

Current Pattern:  the pattern that matched the current problem.  This may include Wild Card characters 
or exact characters.

Category:            the style category of the currently highlighted problem.

If the current pattern is one of StyleWriter’s standard patterns from the main Pattern File, Deleting will 
flag it as Deleted and you can Restore it later if you wish.  If the pattern is one you have added to the 
current Added Pattern File, Deleting will remove the pattern, but it won’t remove the associated message.

Click Delete if you want to delete the current pattern.

Note: If you are using StyleWriter on a network, you may not be able to delete patterns, but you can still 
add exceptions to your own Added Pattern File.  You can make an exception that is the same as the 
pattern you want to delete, effectively cancelling all its matches.

Welcome to StyleWriter Help > Customizing StyleWriter > Tailoring StyleWriter's Patterns
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Make an Exception Pattern

If StyleWriter highlights a word or phrase you do not want highlighted in its particular context, you can 
make an exception pattern so StyleWriter won't highlight it in that context.

The Make an Exception Pattern box shows:

Click Add Exception to make the exception.

Note: If you are using StyleWriter on a network, you may not be able to delete patterns, but you can still 
add exceptions to your own Exceptions File.  You can make an exception that is the same as the 
pattern you want to delete, effectively cancelling all its matches.

Add Category

(Standard and Professional editions only)

Clicking the Add Category button in the Style Categories dialog opens the Add Category window, where you 
can enter a name for the new category.

Current 
Pattern:

the pattern that matched the current problem.  This may include Wild Card characters or 
exact characters.

Category: the style category of the currently highlighted problem.
Exception 
Pattern:

a suggested pattern that will cancel matches on the current matched text but not all the 
possible matches the current pattern will find. 

If the pattern contains wild cards, the exception will be the same as the current matched 
text.

If the matched text is the same as the current pattern, StyleWriter includes the next word 
or a punctuation mark.

You can edit the Make Exception pattern and use Wild Card characters to exclude 
particular cases of the current pattern.  In the example above, the exception has been 
edited to include the following word so the advice will still appear for “required” unless it 
is followed by “wording”.
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The category name will be recorded in the current Added Pattern File with any patterns and messages you add 
to the category.

StyleWriter allows up to four user-defined categories.  Since these are defined in the Added Pattern File, each 
Added Pattern File can have different user-defined categories.

Each category can hold up to 2,047 messages, and each message can have a virtually unlimited number of 
patterns pointing to it.  For more information on adding patterns, see Tailoring StyleWriter’s Patterns.

Welcome to StyleWriter Help > Customizing StyleWriter > Tailoring StyleWriter's Patterns

Reviewing Added Patterns

The Review Changed Patterns window lists the categories, patterns and messages of changes you have 
made while tailoring StyleWriter's patterns.  Select from the four tabs across the top of the dialog to 
display the changes you want to review.
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The first tab shows patterns added to the current Added Pattern File (Standard and Professional editions 
only).

You can decide which patterns you want to keep, or you can add new patterns and exceptions from this 
dialog.

·   Click the Delete button if you have added a pattern you don't want to keep.  The pattern will be 
removed from the Added Pattern File.  The advice message will remain in the file and can be used 
or modified for another pattern.

·   Click in the Advice Message if you want to edit the advice of an added pattern.  If the  advice 
message is being used by any other patterns, you will be asked to confirm before saving.

Sort the patterns by Pattern or Category by clicking on the column heading.

To leave the window, click the Close button.

Welcome to StyleWriter Help > Customizing StyleWriter > Tailoring StyleWriter's Patterns > Reviewing 
Added Patterns

Reviewing Changed Patterns

The Review Changed Patterns window lists the categories, patterns and messages of changes you have 
made while tailoring StyleWriter's patterns.  Select from the four tabs across the top of the dialog to 
display the changes you want to review.

You can decide which changes you want to keep.

·   When you select a Deleted pattern, the Delete button changes to Restore.  Click the Restore button 
to restore a deleted pattern.

·   When you select an Exception pattern, the Restore button changes to Delete.  Click the Delete 
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button if you have added an exception you don't want to keep.  The exception pattern will be removed.

Sort the patterns by Pattern or Category by clicking on the column heading.

To leave the window, click the Close button.

Welcome to StyleWriter Help > Customizing StyleWriter > Tailoring StyleWriter's Patterns > Reviewing 
Added Patterns

Reviewing Dictionary

The Review Changed Patterns window lists the categories, patterns and messages of changes you have 
made while tailoring StyleWriter's patterns.  Select from the four tabs across the top of the dialog to 
display the changes you want to review.

When StyleWriter doesn’t recognize a word and you add it to the dictionary as a Name, it creates a 
pattern that will find the word whether it has a capital or not.  If it doesn’t have a capital, StyleWriter will 
prompt the user to correct it.

You can decide which changes you want to keep.

·   Click the Delete button if you have added a word you don't want to keep.  The word will be 
removed.

Sort the patterns by Pattern or Class by clicking on the column heading.

To leave the window, click the Close button.

Welcome to StyleWriter Help > Customizing StyleWriter > Tailoring StyleWriter's Patterns > Reviewing 
Added Patterns
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Reviewing Temporary Patterns

The Review Changed Patterns window lists the categories, patterns and messages of changes you have 
made while tailoring StyleWriter's patterns.  Select from the four tabs across the top of the dialog to 
display the changes you want to review.

Temporary patterns are exception patterns StyleWriter creates in response to your Ignore All commands.  
They only last while you are checking the current document, so there is no point in Deleting them.

Sort the patterns by Pattern or Category by clicking on the column heading.

To leave the window, click the Close button.
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